PHP is the programming language that WordPress, like most websites, is written in.
WordPress requires at least the 5.4 series of PHP releases to run on.
What PHP versions Shield Security plugin is compatible with?
Shield Security plugin is compatible with any PHP version from 5.4 up to the latest version of PHP (including 7.x).
More information on why we are removing Support for PHP 5.2 can be found here.
One important thing to note here is that, if you use some compatibility tool, i.e. PHP Compatibility Checker to check compatibility with Shield, it can throw warnings.
Other important note: Site Ground will send automated emails that do some code sniffing to attempt to determine compatibility - you can ignore these notices. Incompatibilities appear due to backward-compatible code that has no effect on your sites if they run newer versions of PHP.
Example of the warnings for php7.2 compatibility checking
FOUND 3 ERRORS AFFECTING 1 LINE 37 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead 37 | ERROR | Function mcrypt_create_iv() is deprecated since PHP 7.1 and removed since PHP 7.2; Use random_bytes() or OpenSSL instead 37 | ERROR | The constant "MCRYPT_DEV_URANDOM" is deprecated since PHP 7.1 and removed since PHP 7.2
These warnings can be ignored as they're flagging "fallback" code for older PHP versions.