iControlWP is compatible with any PHP version from 5.2 up to the latest version of PHP (including 7.x). 


One important thing to note here is that, if you use some compatibility tool, i.e. PHP Compatibility Checker to check compatibility with iControlWP, it can throw warnings. 


For example:

 37 | ERROR | Extension 'mcrypt' is deprecated since PHP 7.1 and removed since PHP 7.2; Use openssl (preferred) or pecl/mcrypt once available instead

These warnings can be ignored as they're flagging "fallback" code for older PHP versions.