The Locale Override options can be used if you want to force a language for Shield Security plugin for all users at all times.


Important: We don't recommend setting this unless you're sure of the consequences for all users.


If you provide a locale for which there are no translations, defaults will apply.


Available locales are as follows:

  • ar
  • bs_BA
  • ca_ES
  • cs_CZ
  • da_DK
  • de_DE
  • en_GB
  • en_US
  • es_ES
  • fa_IR
  • fi
  • fr_CA
  • fr_FR
  • he_IL
  • it_IT
  • ja
  • nb_NO
  • nl_NL
  • pl_PL
  • pt_BR
  • pt_PT
  • ro_RO
  • ru_RU
  • sr_RS
  • sv_SE
  • tr_TR
  • zh_CN


For example, if you want to use Shield in Dutch, you just need to go to the General Settings module => General Options => Locale Override => and enter the locale nl_NLĀ and click to save settings:

The language for the Shield plugin will be overwritten from English to Dutch. I.e.

Please note that the language will be changed for the Shield plugin only. This will not change the language of your WordPress dashboard. For example, if you use WordPress in English but change locale to Dutch with Shield, WordPress dashboard will be in English and Shield plugin in Dutch:

If you want to change the language of your WordPress, you can do this through WordPress general settings: